Vision

Our vision is to create a structure that allows us to load all of the characters and models on all the computers with a Poser Install in such a way that Poser is not processing unwieldy and large runtime files if we can avoid it.

When new models/textures get added to one computer, the model should be made available to all the other computers in the form of a “Service Pack.” All the computers should be updated with the “Service Pack” at least once a year. Once the “Service Pack” has been used to update all the computers, it should be distributed to the correct locations in the main /p/hlp/POSER/ directory.

Loading Poser on a Windows PC that has not had a Poser Install Before

Please do not just click “Okay” all the way through the install. At one point you will see a screen asking where you would like to place the “Legacy Folder” or the folder that comes with all the pre-installed content. Create new folders as needed so that you put this folder in ‘’’C:\Poser_Runtimes.’’’

Loading Poser Updates

In /p/hlp/POSER/Updates/ there is a Mac and a Win directory. Each of these has Poser Service Release 3 and Poser Content Update 1 for the appropriate OS. Make sure to install these after doing the basic Poser install.

Loading Poser Models and Textures on a Windows PC that has not had a Poser Install Before

Steps:

  1. Create a Folder in C: called Poser_Runtimes (C:\Poser_Runtimes)

  2. Copy all of the contents of /p/hlp/POSER/FinalRuntimes into this folder.

  3. Open Poser and open the libraries bar on the right side of the screen.
  4. Navigate to the top level of the library directories. You should see two preloaded folders: ‘’’Poser Content’’’ and ‘’’Downloads’’’
  5. At the bottom of this you should see a ‘+’ sign. A mouse-over will say “Add Runtime.” Click on the ‘+’ and find the folder you would like to use (from C:\Poser_Runtimes). You need to make sure that you have the folder “Runtime” highlighted. When you click okay, the textures and models will load into poser.

Setting Your Preferences (Mandatory for FAST rendering and FINDING libraries)

Steps:
1) On a Windows machine: open C:\Users\yourusername\AppData\Roaming\Poser 7\LibraryPrefs.xml with a plaintext editor (e.g. Notepad++ or Vim, not Word) and make sure that you have at least one line pointing to a real library like this:

   1         <ContentFolder folder="C:\Poser_Runtimes\Extras\Runtime\Libraries" index="0" >
   2                 <Library libraryType="2"  curLibraryFolder="character" />
   3                 <Library libraryType="8"  curLibraryFolder="props" />
   4         </ContentFolder>

The first line of this example is the most important line. You may ignore the others as longs as it has a similar form. If you don’t do this, you’ll get an error message when you start up Poser.
If you are having trouble finding this LibraryPrefs file, go into General Preferences, Click on the Misc tab and write down the Path it lists for Temp files.
2) Start Poser. Depending on your project, feel free to delete Simon and focus your camera at a different angle to make a new default starting pose. Go to Edit -> General Preferences.
3) In General Prefences -> Document, feel free to set your preferred state and mark “launch to Preferred State.” Also mark the ‘’Undo’’ from 100 down to 10 or 12 at the highest (depending on how many times you’ll ever want to hit ctrl-z). Smoothing creases should be around 80.
4) In the Library Tab, set your Double-Click Behavior to Add to Scene and your File Search to Deep. Also click on the Apply Universal Poses box.
5) For the Render Tab, click on the Adaptive bucket. Set the Memory limit buffer high (~64) and set the number of threads up to 4. This ‘’’should’’’ force Poser to use more memory while it renders, thereby speeding it up.

File Location and Size

The Runtime Folders are located under /p/hlp/POSER /p/hlp/POSER/FinalRuntimes = 8GB to copy everything

in Extras/Runtime
/textures is 412 MB
/geometries is 332 MB
/Libraries is 619 MB

in Principal/Runtime
/textures is 2.2 GB
/geometries is 1.42 GB
/Libraries is 2.52 GB

File Library

Currently under construction, this file will serve as a database for finding the poser models and textures.

How to Find New Props, Characters, Poses, and Textures

We have a lifetime membership to the PoserWorld archive, where we can get models and textures. For details see: here. If you can’t find what you’re looking for in Poser World, check the follwing websites:
- Paradise Check out the “Free stuff” link on the sidebar.
- Renderosity’s free section
- Turbosquid
- PlanIt 3D
- Digital Dreams This website is not all poser models but it is very useful.

How to Install New Content

An excellent overview of how to process the .zip files that you've downloaded can be found at this [http://www.cocs.com/poser/organizingzipfiles.htm website]. I recommend reading through this before you ever start trying to download new files.

In our case we want all of the .obj files to be saved in the top level of Runtime/Geometries and all texture files (.jpg, .bmp, .png) to be saved in the top level of Runtime/Textures. This way if we run into problems where the texture maps won't load, it's a lot easier to search. Following the guidelines in the website above, modify the .cr2 or .pp2 file accordingly in notepad.

After you have successfully loaded your new character, copy the file and all of its supporting files into the "Service Pack" for the time period. If you are the first person to start the current "Service Pack" Use the folder /p/hlp/POSER/TemplateForPoserZIPFiles to make the next Service Pack. Copy this folder and rename it as ServicePack_timePeriod. We will update all the computers at the end of the summer and each semester.

For the last few suggested websites, you are only importing the geometries. Poser accepts .3ds, .obj, and .lwo models. To load these new models, inside Poser hit File -> Import and then select the file type. If the object comes with a texture, save the texture in Runtime/Textures, go to the material room and apply the file. When you’re done, hit the ‘+’ button to save the prop permanently in poser. Now take the texture file, .obj file, and .pp2 file, copy them, and put them inside the "Service Pack" accordingly.

How to Make New Content

New models and textures can be made with Blender (installed on all computers) and (definitely) PoserPro (installed on the Dell named Poser).There's a free wikibook for Blender called Noob to Pro.

After Making a Face in the Face Room

Always click on Scripts -> PrintInfo -> listfiles and find out where Poser has saved the new texture and geometry on your computer. Move it into the current runtime folder and the service pack so that you can use it again in the future. (I often find the texture in your local profile on a windows machine i.e. khousel/AppData/Local/VirtualStore/e frontier/Poser 7/Tue_Jan_1_etc)

How to Work with “Service Packs”

Plan: Install all the new models on every Posing computer regularly.
File location: /p/hlp/POSER/Service Pack

1. When to add to a "Service Pack"

  1. When you make a new face in the face room.
  2. When you import an object or character to poser.
  3. When you download or create a new texture to use on an existing object.
  4. When you create a new object using basic shapes.
  5. When you save a specific pose or hand. (info stored in the main library file)

2. Method:

  1. Load the object and make sure it's working and it's links are correct.
  2. Open the pre-existing service pack, or copy and rename the template folder and add the files to the correct locations. See the previously suggested website.

  3. At the end of the summer or semester, copy the contents of the "Service Pack" right on top of the existing folder in C:\Poser_Runtimes on all the computers in the lab.

  4. Copy the contents of the "Service Pack" into /p/hlp/POSER/FinalRuntimes.
  5. Delete the current "Service Pack."

HlpLab: PoserAddons (last edited 2015-02-13 15:15:39 by AndrewWatts)

MoinMoin Appliance - Powered by TurnKey Linux