Working with Prism 4.0

Basics

When you launch Prism 4, you’ll see one of the following windows (which one appears will depend on the settings of the last user).

Open_Type of Graph.png Open_Format of Table .png

Choose whether you want to create a new file, or open an existing file. If creating a new file, you’ll next need to choose the appropriate format for your data table.

Data table setup

There are two methods for choosing the layout of the Data Table: 1) based on X and Y format (left window) or 2) based on Type of graph (right window). Use whichever method you find most intuitive. Note the button at the top that enables you to switch to the other method.

For now, set the parameters as in one of the figures above: this would be appropriate for a t-test where you want to input individual data points.

Your data table will look like the image below, left.

Enter the Blood Pressure data from the Wiki, placing each data set into a different column, starting with the left-most column. Label the columns (click header). Also on the left sidebar, label the data table “e.g., “Blood Pressure Data”.

attachment:Data Table empty.png attachment:Blood Pressure data table individ.png

There are several other things in this window to notice:

NOTE: There are times you may want to enter data as mean, SD (or SEM), n. These options are given in the Data Table setup window. In the current example, if you select Change>Format Data Table, you could reformat the table to receive group statistics rather than individual data points. The figure below shows the data window formatted for means/SD. Just be careful when choosing this format: if you choose mean/SD format but enter mean/SEM data, your statistical calculations will be incorrect!

Blood Pressure Data table means.png

Graphs

As soon as you create a data table, Prism also creates a graph.

Blood Pressure Graph_Initial.png

For the Blood Pressure data entered in this tutorial, the default graph might looks like the figure on above. Again, the particular form of the default graph (scatterplot, histogram, box/whisker, etc) depends on the prior user. You can modify the format by clicking on CHANGE>Graph type. You can modify virtually all other elements of the graph by clicking on the axis, text, etc, or by selecting an option available in the CHANGE menu.

Blood Pressure Graph_ Modified.png

This is the same Blood Pressure data after making various changes in the graph format. In addition to plotting as histograms, note that the Y axis is now labeled appropriately and the fill/pattern in the bars has been changed, (just double click one of the bars, and a window will open to change various features).

Note that if you choose NEW>graph of existing data, you can create another graph of the data rather than modify the format of an existing graph. If you do this, you should title the graphs appropriately so you can differentiate one from another.

Analysis setup

Once a Data Table is filled and labeled, click the “Analyze” button. The following window will appear:

Analyze window_t.png

Under Analysis select “Built-in analysis.” Under Type select “Statistical analyses.” Select “t-tests (and nonparametric t tests).” Under Data to analyze select “All data sets.” Click OK.

Next an Analysis Parameters box (shown below) allows you to select the statistics that you want calculated. For now, select unpaired, parametric t-test. Click OK.

Parameters_unpaired t.png

Results

You should now see the tabular results (shown below) of the analysis selected. This window describes which data table was analyzed, what type of analysis was run, and the results of that analysis. Note that in this example, t=0.4542, df=18. The p = .6551, therefore the means are not significantly different from one another. Some additional statistics are also reported, including means +/- SEM, and the results of an F test to compare whether the variance in the two groups differ significantly (if they do, a nonparametric t-test should instead be run by going to the CHANGE tab and choosing a nonparametric test)

Blood Pressure Results_unpaired t.png

NOTE: If you realize that a paired t-test should have been used, this is easily corrected. Be sure you’re in the Analysis window; click on CHANGE. The Analysis Parameters box will reopen, and you can change to a paired t-test. The results window will now specify that the statistics reported are for a paired t-test. If you do this for the Blood Pressure Data, the results will now yield t=2.024, df = 9. The p=.0737, a value that approaches statistical significance (and is MUCH smaller than that obtained from an unpaired t-test).

Column Statistics

Description: Column statistics give a basic set of descriptive statistics (mean, median, standard deviation, etc.) for a set of data. It is usually a good idea to obtain column statistics for each data set since it can facilitate spotting mistakes in your data entry.

Column statistics can be obtained for most data table formats. However, note that for an XY graph, column statistics will only be given for the Y variable.

From the data table, choose >ANALYZE>Statistical Analysis>Column Statistics.

Select the particular statistics you want calculated. Click OK.

Select Parameters_Column Stats.png

One-way ANOVA

Description: A one-way ANOVA compares the means (or medians, if nonparametric) of three or more groups that differ on only one dimension (independent variable). The test determines if there is a significant main effect of that variable. In order to determine which groups differ, you must perform post-hoc t-tests.

Table setup:

Analysis setup:

Analyze Window_Anova.png

Next you will be prompted with an Analysis Parameters box.

Parameters_1-way.png

Normally you will use the default selections under Choose Test, but if you are performing a repeated measures test or if the data is not Gaussian, be sure to check the appropriate boxes. If you want post-hoc t-tests, select the appropriate choice under Post test (the Tukey or Bonferroni post-hoc tests are used most often).

Click OK.

Results:

You should now see the tabular results (shown below) of the analysis selected. This window describes which data table was analyzed, what type of analysis was run, and the results of that analysis. Note that for the data on TV watching given in the Wiki, the overall F=.9188 and df = 2,12 (df for treatment=2, df for residual=12). The p = .4253, therefore there is no significant main effect of academic major on # TV hours watched per week. Also reported in this table are the results of Bartlett’s test, which evaluates whether there are significant differences in variance across groups (if there are, nonparametric statistics should be used – use the CHANGE tab to select a different test). The results of the posthoc tests are reported at the bottom of this page. In the present example, there are none of the posthoc comparisons are statistically significant.

Results_Anova unmatched.png

NOTE: If you realize that repeated measures ANOVA should have been used, this is easily corrected. Be sure you’re in the Analysis window; click on CHANGE. The Analysis Parameters box will reopen, and you can select repeated measures. The results window will now specify that the statistics reported are for a RM ANOVA. If you do this for the TV watching data, the results will now yield F=4.696, df = 2, 8 (df for treatment=2, df for residual = 8). The p=.0448, suggesting that a significant amount of the variance in the data can be accounted for by academic major. Posthoc t-tests reveal that NSC majors watch significantly more hours of TV/week than do “Other” (nonBCS/nonNSC) majors. Again, notice that the pairing (repeated measures) had a major effect on the outcome of this analysis.

Results_Anova RM.png

Two-way ANOVA

Description: A two-way ANOVA is used when the experimental design investigates the effects of two different independent variables (e.g. sex AND age). The test tells you if there is a significant main effect of each variable, and if there is a significant interaction between the two independent variables.

Table setup:

Format Table 2way.png

Label the columns and rows, and enter the Spine Density data from the Wiki, placing each data set into the appropriate column and row. Also on the left sidebar, label the data table “e.g., “Spine Density: Treatment”. We’ve appended the name “treatment” to this because the format shown below will give posthocs for the effect of treatment (at each age). As explained below, you’ll need to create a different data table with the data reformatted to get posthocs for the effect of age (in each treatment group). For now, your data table should look like:

Spine density data treatment.png

Analysis setup:

Spine density analyze .png

Results:

You should now see the tabular results (shown below) of the analysis selected. Note that for the data on spine density (given in the Wiki), there is a significant main effect of treatment (F(1,16) = 40..65, p<.0001), age (F(1,16) = 5.04, p<.05) and a significant interaction between these two variables (F (1,16) =6.782, p<.02).

Spine density Results.png

Interpreting two-way ANOVAs:

Posthoc tests: The results of the posthoc tests are reported at the bottom of the ANOVA results page. In the present example, they reveal that prenatal cocaine exposure results in a significant reduction in spine density that is evident at both 4 and 12 weeks of age (4 wks: t=2.67, p<.05; 12 wks: t=6.35, p<.001).

Spine density posthoc1.png

As shown above, the posthocs done in Prism 4.0 only compare group differences between columns (in this case, between treatment groups). Since we would also want to know if there is a significant effect of the other factor (e.g., age) within each treatment group, we need to reformat the data table so that columns represent different ages, rows represent different treatment groups (Note: Prism 6.0 allows the user to do all relevant posthocs without reformatting the data).

Transposing the data:

Analyze transpose.png Transpose Parameters.png

This makes a new sheet of the transposed data in the RESULTS folder. To get this into a data table that can be analyzed:

Now, if you analyze that data table with a 2-way ANOVA (make sure your labels for Columns and Rows for ANOVA Parameters are correct for this transformed data), you should get the other set of Posthocs at the bottom of the Results page (all main effects will be the same):

Spine density posthoc2.png

Exporting Data/Graphs from Prism

Prism saves files in the .pzf format, which is meaningless to anything but Prism

There are several ways to get your files to a readable format elsewhere

Go back to the Homepage

Using-Prism (last edited 2014-09-24 12:22:47 by KathyNordeen)